Exchange /hosting discontinued

Everybody that has hosted Exchange 2010 running using the /hosting switch knows it is a real painful experience. It is difficult to implement, it is difficult to maintain and there quite a lot of functionality missing like UM, Public Folders, the Exchange Management Console and integration with other products like Lync Server 2010 or Sharepoint Server 2010.

There has been a lot of complaints from hosters about this situation at Microsoft and Microsoft had to make a painful decision: Microsoft will no longer invest in the /hosting version of Exchange Server 2010 and it will be discontinued in the next version of Exchange Server (code name Exchange 15).

Continue reading Exchange /hosting discontinued

Error 600 Invalid Request

It is possible to test the autodiscover configuration using a browser. But when navigating to the autodiscover URL https://autodiscover.contoso.com/autodiscover/autodiscover.xml you’ll see a 600 Invalid Request error message.

image

When you click the Show All content button the entire XML package is shown:

image

When you see this message your autodiscover configuration is absolutely fine! The reason you see this message is that the autodiscover service expects an HTTP POST command from Outlook, and not an HTTP GET command from Internet Explorer.

So, the service is good but the actual request that’s send to the autodiscover service is not good and therefore autodiscover returns the Error 600 Invalid Request message. So this error is good 🙂