Installing MS13-061 breaks CI on Exchange Server 2013

Preliminary information and subject to change! Will update when more information becomes available.

When installing MS13-061 on Exchange Server 2013 CU1 or CU2 issues with the Content Indexing (can) occur. Content Indexing for Mailbox Databases are in a failed state and the existing “Microsoft Exchange Search Host Controller” seems to be missing. Instead there’s a new service called “Host Controller Services for Exchange” on the box.

Right now it looks like it doesn’t affect Exchange Server 2007 or Exchange Server 2010.

There’s a workaround to get this fixed:

Open the Registry Editor and navigate to the following path:

“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Search Foundation for Exchange”

Go to the DataDirectory string and give it the following value:

C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data

image

Note. If your Exchange binaries are in a different directory use change the path accordingly.

In the registry navigate to the following location:

“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HostControllerService”

Change the value of “DisplayName” to “Microsoft Exchange Search Host Controller”

Add a new Multi-String Value named “DependOnService” and specify “http” in Value data.

image

The display name will only be changed after a reboot of the server, but the services can be started at this point.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s